vWAAS Config using WCCPv2-GRE

This is a pretty basic WCCP-GRE configuration that i used to get my vWAAS lab up and running.

The WCCP GRE redirect method establishes a dynamic tunnel, without any real tunnel configuration for it to work and handled entirely by the WCCP process.

vWAAS Configs

Router config:

ip wccp version 2
ip wccp source-interface Loopback0
ip wccp 61 group-list 1
ip wccp 62 group-list 1
!
interface Loopback0
ip address 172.22.39.1 255.255.255.255
!
interface GigabitEthernet0/0
description [LAN Interface]
ip address 172.22.39.65 255.255.255.248
ip wccp 61 redirect in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description [WAN Interface]
ip address 10.10.10.2 255.255.255.0
ip wccp 62 redirect in
duplex full
speed 100

vWAAS Config:

wccp router-list 1 172.22.39.1
wccp tcp-promiscuous service-pair 61 62
router-list-num 1
redirect-method gre
egress-method wccp-gre
enable

Configuring vWAAS

Once the VM (.ova) file has been deployed (version Cisco vWAAS-750-5.4.1-b34.ova in this case) on to the UCS-E Server.  We can configure the vWAAS settings.  You can do this either by running through the ‘setup’ command, or use the values from below.

From the vCentre client, choose the console tab and log in to the vWAAS Console.  The default is userid and password are admin/default.

IP and Netmask
vWAAS(config)# interface virtual 1/0
vWAAS(config-if)# ip address 172.22.36.2 255.255.255.0
vWAAS(config-if)# exit
Default gateway using the ip command:
vWAAS(config)# ip default-gateway 172.22.36.1
vWAAS(config)# ip primary-interface virtual 1/0
Ping the IP addresses of the default gateway and Central Manager to verify they can be reached before continuing to the next step then add the Enterprise license using the license command:
vWAAS# license add Enterprise
Add the Central Manager address using the central-manager command:
vWAAS(config)# central-manager address 172.22.x.x
Enable CMS to register with the Central Manager using the cms command:
vWAAS(config)# cms enable
Once registered with the CM, then your device will appear in the console under devices.
The versions will need to be the same.

UCS-E160D and CIMC

As part of a vWAAS deployment on a 3945-ISR-G2, my objective was to access the UCS-E server, initially the CIMC interface for the install of ESXi and then vWAAS, via the /29 address i’d allocated.

Here’s a much nicer look at that configuration.

interface GigabitEthernet0/0
 description [Link to 3850]
 ip address 172.22.39.65 255.255.255.248

interface ucse 4/0
 description [UCS-E Series CIMC Link]
 ip unnumbered GigabitEthernet0/0
 imc ip address 172.22.39.67 255.255.255.248 default-gateway 172.22.39.65
 imc access-port shared-lom console

interface ucse4/1
 switchport mode trunk

ip route 172.22.39.67 255.255.255.255 ucse4/0